Upgrade Joomla 2.5 to 3.0

If you were working on Joomla 1.5 and tried to do the upgrade to 2.5, I’m sure you remember the big fiasco that the upgrade was.

Joomla team promised a decent upgrade to the next one. So here we are.

I have followed the steps to upgrade, and this is my personal experience.Till here, easy.

Then: “Your host needs to disable magic_quotes_gpc to run this version of Joomla!”. After some hours changing parameters in the .htaccess, php.ini, etc. Finally I discover that the configuration of the multi-hosting we use requires the administrators to do it, so 5 minutes later it was done 🙁

Finally it was the only hurdle of the new environment, now we will have to learn about the new features, and tricks to make the application works with a nice style.